Download Lotus Symphony 1.2 for the Mac

November 3 2008

You can download the Lotus Symphony 1.2 for Mac beta from here right now

2 Responses to “Download Lotus Symphony 1.2 for the Mac”

  1. 1) Curt Stone says:

    My excitement has been squashed. It requires OSX 10.5 and alas I have 10.4.

  2. 2) John Head says:

    10.5 had a bunch of fixes for Java that makes Eclipse work on the mac ... you need to upgrade Curt .. same restrictions for the 8.5 client

Leave a Reply